PDA

View Full Version : [Vegas] Issue opening Avatar (from Blu-ray) in Vegas



Kevinicus
05-05-2010, 11:49 PM
I'm trying to get started on an edit of Avatar and I got the .iso file on my computer from the disc and I've pulled out the the .mt2s file for the movie. I can watch the file perfectly fine, but whenever I try to open it in Vegas, the program locks up. It doesn't even actually try to open the file before locking up either. I'll go to import files and go to the folder holding the file and it's listed, but when I try to highlight it, not even open it, it locks up. Does anyone have any idea on why it would do this?

I also tried to open it in NeroVision, but that locked up too, but it at least let me highlight it and started to analyze the file. Nero isn't the most stable thing in the world, so it might have just been a fluke, I haven't tried again yet.

elbarto1
05-06-2010, 12:38 PM
I didnt even know vegas could open m2ts files.

what happens when you drag and drop?

Kevinicus
05-06-2010, 06:59 PM
It freezes up.

I was able to open it up in Nero and export it to a different file, but lost the subtitles.

Ghostcut
05-09-2010, 08:28 PM
The Avatar Blu-ray has a new form of DRM that among other things has required a load of existing Blu-ray players to get firmware updates. This may be your problem. The latest version of AnyDVD will bypass it.

Kevinicus
05-10-2010, 01:26 AM
Oh, I already got it through AnyDVD HD and onto my computer. That was no problem. The issue was with the specific .mt2s video file. I've found a work around through Nero, but now my issue is the forced subtitles. I'd rather not have to go back through and recreate them all...though that does give me flexibility to change them.